1、根据错误安装对应版本的Python :

    sudo apt-get install python3.7

2、升级

    python3.7 -m pip install --upgrade pip