此原因为redis版本兼容问题,需要换一个redis版本安装。

我之前装的redis版本为6.0.6,改为5.0.8有用。

但是宝塔面板只有6.x版本的redis可以装,怎么办呢?

这里就需要我们自己自定义安装其他版本了。

1.先在面板安装默认redis 然后卸载

2.修改/www/server/panel/install/redis.sh文件

指定版本 指定为5.0.8 修改后保存

3.连接ssh 执行以下命令安装redis即可(root权限),或宝塔任务计划

bash /www/server/panel/install/redis.sh install

4.安装完了,还需要在php设置里安装redis扩展

操作完以上步骤,去网站后台开启redis,可以正常访问了。